Phone & Ticket System Outage
Incident Report for TempWorks Software
Resolved
We have completed our monitoring of the fix that was implemented and all services are fully operational. If you are still experiencing any issues, please contact our Support team at 651-452-0366.
Posted Dec 08, 2023 - 12:42 CST
Investigating
We are currently experiencing technical difficulties with our phones and integrated ticket creation through email.
Please contact us through live chat at https://www.tempworks.com/live-chat/ or by logging into https://bridge.ontempworks.com to create a ticket or review any open tickets.
Posted Dec 04, 2023 - 04:05 CST