Microsoft 365 Service Degradation (Email & Related Services)

Incident Report for TempWorks Software

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 07:01 CST

Identified

Microsoft has reported a service degradation affecting Microsoft 365, which has impacted our ability to send and receive emails, along with other related services.

If you need assistance during this time:
Submit a support ticket via our Support Help Center, or
Contact our support team directly at 651-452-0366
Posted Jan 22, 2026 - 15:13 CST