Phone System Outage – Inbound and Outbound Calling Unavailable

Incident Report for TempWorks Software

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 06:59 CDT

Identified

Our third party phone vendor has identified the issue and is applying a fix.
Posted Jun 12, 2025 - 14:13 CDT

Investigating

Our third party phone vendor is currently experiencing an outage that impacts our ability to make or receive calls. Please email twsupport@tempworks.com to generate a support ticket or use our live chat feature if immediate assistance is needed.
Posted Jun 12, 2025 - 13:50 CDT