E-Verify Access Issue (Enterprise & Beyond)

Incident Report for TempWorks Software

Resolved

This incident has been resolved.
Posted Apr 22, 2026 - 09:18 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2026 - 09:06 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 22, 2026 - 09:02 CDT

Investigating

We are currently aware of an issue impacting E-Verify functionality for customers in Enterprise and higher tiers. Users may encounter a 403 Permission Error when attempting to access or process E-Verify requests.

Our team is actively investigating the root cause and working to restore full functionality as quickly as possible.
Posted Apr 22, 2026 - 08:55 CDT