HRCenter Performance Issues
Incident Report for TempWorks Software
Resolved
The performance issue has been fully resolved. If you are still experiencing any performance issues, please contact support at 651-452-0366. We apologize for any inconvenience.
Posted Sep 05, 2023 - 15:48 CDT
Monitoring
We have implemented a fix for the HRCenter performance issue and are monitoring the recovery of impacted systems. If you are still experiencing slowness in HRCenter or HRCenter Admin, please contact our support team at 651-452-0366.
Posted Sep 05, 2023 - 15:39 CDT
Investigating
Our infrastructure team is investigating a performance issue that may be causing slow response time to HRCenter and HRCenter Admin Services. We apologize for the inconvenience and will send updates as they are available.
Posted Sep 05, 2023 - 15:28 CDT
This incident affected: HRCenter (HRCenter (Employee), HRCenter (Admin), Convert Service).