Phone System Outage

Incident Report for TempWorks Software

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 18:54 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 01, 2026 - 14:37 CDT

Investigating

We are currently experiencing an issue with our phone system provider, which is impacting our ability to take inbound calls.

Our provider is aware of the issue and is actively working to restore service. We are monitoring the situation and will provide another update as more information becomes available.

Please submit a ticket via our Help Center if immediate assistance is needed. Thank you!
Posted Sep 01, 2026 - 12:29 CDT